The i30 Owners Club

HOW TO: UPGRADE YOUR GD-01/GD-02 TO A GD-03 HEAD UNIT STEP-BY-STEP GUIDE

VTH · 436 · 114407

0 Members and 1 Guest are viewing this topic.

Offline Maximus12234

  • 2nd Gear
  • *
    • Posts: 11

    • au Australia
      Perth
So an update to my previous post. I recieved the head unit, usb lead and jack assemby and fitted it all as per the instructions, and bam, head unit works but USB module isn't working

not taking a charge at all, does that mean i can't update the firmware? as that means i'd need to plug the firmware update in through the USB port?

Not sure what else to do, as i sourced all the three new parts from the same vehicle
  • i30 2012


Offline CraigB

  • Global Moderator
  • *
    • Posts: 10,835

    • au Australia
      Perth, WA
I think you’re about the third person to recently have no power to the USB port after the install, it’s got me baffled as to why this is happening as it’s generally a plug an play setup  :confused:


Offline Maximus12234

  • 2nd Gear
  • *
    • Posts: 11

    • au Australia
      Perth
Yeah i'm not sure whether it's the USB cable, aux/usb module, or the actual head unit that's the problem. Everything works atm apart from the USB connection  :crazy1:

i'll take it apart and test it all uninstalled this arvo. Just checking that the AUX/USB module only needs the USB cable connected to work? The aux part isnt connected to anything atm.

Just really annoying :(
  • i30 2012


Offline CraigB

  • Global Moderator
  • *
    • Posts: 10,835

    • au Australia
      Perth, WA
Yeah i'm not sure whether it's the USB cable, aux/usb module, or the actual head unit that's the problem. Everything works atm apart from the USB connection  :crazy1:

i'll take it apart and test it all uninstalled this arvo. Just checking that the AUX/USB module only needs the USB cable connected to work? The aux part isnt connected to anything atm.

Just really annoying :(
Yes it's only the USB cable that's required, I can't remember if the USB lead only plugs in one way...thinking it's directional :undecided:

Is it a blue plug black cable as pictured in the first post of this topic?


Offline Maximus12234

  • 2nd Gear
  • *
    • Posts: 11

    • au Australia
      Perth
I shall take photos when i get back from work, but yes the cable and assembly were identical to the photos. From a 2017 i30 i think.
  • i30 2012


Offline CraigB

  • Global Moderator
  • *
    • Posts: 10,835

    • au Australia
      Perth, WA
From a 2017 i30 i think.
Should be 2015 till 2016 for a GD-03 unit, later than that would be another model stereo.


Offline Maximus12234

  • 2nd Gear
  • *
    • Posts: 11

    • au Australia
      Perth
my receipt said (GD-03), GD, 2/2015-02/2017

i'm assuming that means there were models released in 2015, 2016 and 2017 with the GD-03 stereo?

idk, you know a lot more than i do about cars ahah
  • i30 2012


Offline Maximus12234

  • 2nd Gear
  • *
    • Posts: 11

    • au Australia
      Perth
Either way, the head unit and USB module fit perfectly. Just no charge or connection through the USB port. Acting like a dead port. Should there be any lights in the USB module? Should the text light up? Cause i aint seeing any lights either
  • i30 2012


Offline CraigB

  • Global Moderator
  • *
    • Posts: 10,835

    • au Australia
      Perth, WA
Should there be any lights in the USB module? Should the text light up? Cause i aint seeing any lights either
There's no lighting on the module.


Offline Maximus12234

  • 2nd Gear
  • *
    • Posts: 11

    • au Australia
      Perth
I have taken apart the unit again and tried with it all taken apart, still dead, i bought a replacement cable from kia just then, so lets hope that works!
  • i30 2012


Offline Maximus12234

  • 2nd Gear
  • *
    • Posts: 11

    • au Australia
      Perth
I noticed you're in perth too, you happen to know where i can find the USB cable wiyhin a day or so? Do you or anyone you know happen to be selling one?
  • i30 2012


Offline CraigB

  • Global Moderator
  • *
    • Posts: 10,835

    • au Australia
      Perth, WA
I noticed you're in perth too, you happen to know where i can find the USB cable wiyhin a day or so? Do you or anyone you know happen to be selling one?
Possibly through Hyundai Parts an Service :undecided: you might be able to match something through JayCar but whether it'll function correctly with an Apple device I wouldn't know.

I got mine with the unit from Stanvac Korean Auto Parts.

I wonder if the few units recently that are having these same issues are all bought from the same wreckers :undecided: just seems odd that there has been no connection problems with any of these units for years then all of a sudden in the last few months there have been three with the same USB problem, there hasn't been any firmware updates released that could have screwed things up either.


Offline Maximus12234

  • 2nd Gear
  • *
    • Posts: 11

    • au Australia
      Perth
I got mine from tonys auto wreckers in perth, picked it up after work with both the usb cable and aux/usb module

but yeah i don't see the kia replacement cable coming anytime soon

  • i30 2012


Offline Maximus12234

  • 2nd Gear
  • *
    • Posts: 11

    • au Australia
      Perth
anyone know where i can buy the aux/jack assembly? already picked up the cable? willing to buy brand new
  • i30 2012


Offline biggerz

  • 1st Gear
  • *
    • Posts: 7

    • au Australia
      Sydney
My head unit was bought in South Coast NSW and Jeff got his (two in fact) from Ultimate Jap on eBay.

  • 2014 Hyundai i30


Online jprice46

  • 1st Gear
  • *
    • Posts: 4

    • au Australia
      Australia
  • 2015 i30 (with a mostly functional GD-03)
Yeh I'm still gazumped here.  No voltage of the port.

I tried the dealer (Westpoint Auto Brisbane) and they flatly said "nope not interested" (even when I'm happy to pay the $155/hr rate).
I tried a small car audio guy, hoping they'd like to have a crack at it (and be paid for it).  Nope, he said car compatibility means its not worth his time/rate, and would steer me towards an aftermarket replacement.

I still feel like its a logic condition (say +1V on the aux-detect pin) which is preventing the usb port from activating, but I don't have the tools or skills to effectively troubleshoot it.  Or its a hidden software setting which is a simple usb enable/disable.

PM me if you'd like to buy a discounted GD-03, aux unit, and aux-usb cable and try your luck.

I'll remain in innocent hope that someone finds a solution, before I remove the GD-03 and put the GD-02 back in so that I have access to usb charge/ipod mode from the old aux unit.

Looks like I'll have to wait until a new car to get carplay. 
  • 2015 i30


 


SimplePortal 2.3.5 © 2008-2012, SimplePortal