Author Topic: GD-01 Head Unit no sound issue, possible fix  (Read 771 times)

0 Members and 1 Guest are viewing this topic.

  • *
  • Posts: 16
  • au Australia
    Sydney, Australia
GD-01 Head Unit no sound issue, possible fix
« September 13, 2021, 03:58:50 »
My GD-01 head unit suffered the dreaded 'no sound' issue.  Initially I could get sound by pressing the on/off button repeatedly, but eventually even that failed to work.  I got a quote for $330 to fix it, which is crazy, as I could install a better unit for less money.  In another Hyundai forum, someone mentioned that they fixed their (different) unit by discovering that the screws that hold down the main board, and earth it to the chassis, were loose.  With nothing to lose, I removed the unit (very easy to do) and with half a dozen screws, gained access to the main board.  Sure enough, all 4 securing screws were loose.  They even have earth symbols on the board next to them.
I tightened the screws and reinstalled the unit.  It has had about a dozen ignition cycles so far and works every time.  I'll let you know it it stays fixed, but so far so good.  The FM radio is still weak, but I think that's a failed RF amplifier in the roof.
The holding screws tighten down onto earthing pads, and these are covered in solder.  That's a no-no as solder is soft and creeps with time, resulting in the screws coming loose.  I'm surprised that it was built this way, as solder creep is well known in the electronics industry.  Usually the pads are bare copper, and a star washer is fitted to bite and make good contact.



  • GD manual diesel wagon

  • *
  • Posts: 42,899
  • england England
    Manchester, UK
    • i30 Owners Club
Re: GD-01 Head Unit no sound issue, possible fix
« Reply #1 : September 13, 2021, 04:06:37 »
Great feedback :victory:
  • Ioniq MY2018 SE Premium Hybrid in Polar White with added oomph

  • *
  • Posts: 4,305
  • au Australia
    Tura Beach ( Deep Deep South Coast) NSW
Re: GD-01 Head Unit no sound issue, possible fix
« Reply #2 : September 13, 2021, 06:44:07 »
Good job Dave,
Centre stand and sound system fixes . :goodjob2:
  • 4/18 Kona H/lndr 1.6T 7dct & 2/18 DM5 Santa Fe H/lndr 2.2 6sp (9/16 Active X)

  • *
  • Afghanistan Vet
  • Posts: 16,265
  • au Australia
    Adelaide
  • Callsign GUNZ
Re: GD-01 Head Unit no sound issue, possible fix
« Reply #3 : September 13, 2021, 09:25:42 »
I was forming a mental picture of star washers before I got to where you mentioned them. Disappointing shortcut in the assembly process. Great job saving a lot of needless expense. :victory:
  • Frugal Firty: FDSLXCRDi5spHyperSilverBodyKit+Mods &amp MrsG'#039s PDSRPremAuto

  • *
  • Posts: 10,817
  • au Australia
    Perth, WA
Re: GD-01 Head Unit no sound issue, possible fix
« Reply #4 : September 13, 2021, 11:22:33 »
Good fix it job, well done :goodjob2:

Wouldn't of helped with my GD-01 unit as it went bang with smoke an all...totally dead :rip:

  • *
  • Author
  • Posts: 16
  • au Australia
    Sydney, Australia
Re: GD-01 Head Unit no sound issue, possible fix
« Reply #5 : September 13, 2021, 20:03:04 »
Good fix it job, well done :goodjob2:

Wouldn't of helped with my GD-01 unit as it went bang with smoke an all...totally dead :rip:


The ultimate "no sound" issue.....
  • GD manual diesel wagon

  • *
  • Posts: 8
  • au Australia
    Brisbane Queensland
Re: GD-01 Head Unit no sound issue, possible fix
« Reply #6 : September 21, 2021, 05:19:41 »
Well done Dave, glad you sorted it . My GD-01 radio wouldn’t receive anything FM or AM when I bought it second hand. After a series of technician bumps and it intermittently working, I pulled out the FM /AM front end module and re-soldered the IC inside. Hasn’t skipped a beat in a few years now. I hope yours is now also as reliable .
  • 2013 GD 5 Door Hatch, Diesel, 1.6lt, Manual, 6spd, Red

  • *
  • Author
  • Posts: 16
  • au Australia
    Sydney, Australia
Re: GD-01 Head Unit no sound issue, possible fix
« Reply #7 : September 26, 2021, 22:55:03 »
Unfortunately it has started playing up again.  Still working, but sometimes requiring a power cycle or two.  The fact that disturbing it made it go from not working to working for 2 weeks seems to indicate a dry joint or board crack.  I think I'll look for an Android unit to replace it if I can get one at a decent price, not wanting to spend $600 on a Sony....
I think Richo123 has the solution, but what is "a series of technician bumps" ?
 
  • GD manual diesel wagon

 


anything
SimplePortal 2.3.5 © 2008-2012, SimplePortal