The i30 Owners Club

ESC Light and Tacho reading 0

0 Members and 1 Guest are viewing this topic.

Offline merlin032

  • 1st Gear
  • *
    • Posts: 1

    • au Australia
      Victoria, Australia
Hey guys,   we have a 2012 Model i30 GD 1.8 litre Petrol, Manual Transmission.

We have an intermittent fault, where the ESC Light (the one with the car and the wavy lines) will come on, and the Tachometer will be stuck on 0.   It's happened a few times in the past 2 weeks.

I've seen a couple of posts of people reporting this issue when the car goes over 50km/h,  but this is not the case for us.   I've also seen it reported in conjunction with poor running, but this is not happening either.   The car runs and drives normally,  just the light + no tacho  (and presumably ESC isn't working either!)

Has anyone else had this issue? Any ideas on the cause?  Many thanks.
  • 2012 GD 5 Door Hatch, Petrol 1.8lt, Manual, White


Offline baden

  • 1st Gear
  • *
    • Posts: 1
Do you have problems starting the car?

I have a I30 petrol and for a couple of weeks now I have been having trouble starting the engine when it is warm (when you have stopped the car for 15-30 min. after driving for a while).

The symptoms are troubles starting the car, rpm reading 0 and EPS Off light on on the dashboard.

After replacing the battery and reading several threads,  I think it could be a faulty crank shaft sensor
  • Hyundai I30 1.6 2010


Offline Lorian

  • V.I.P
  • *
    • Posts: 3,402

    • gb United Kingdom
      Midlands

  • Midlands, UK N-Line T-GDi
pull the engine codes with a reader - but Crankshaft Sensor is up there as a candidate.


Unread Posts

 


SimplePortal 2.3.5 © 2008-2012, SimplePortal