The i30 Owners Club

Washer issue

0 Members and 2 Guests are viewing this topic.

Offline A Duke

  • 1st Gear
  • *
    • Posts: 4

    • gb United Kingdom
      Scotland north Lanarkshire
 :crazy1:
Sorry if this has been discussed but couldn’t find much on this, unless looking in wrong place.
I have a i30 1.6 GD hatch
Out of the blue washer stopped working. 66 plate and now out of warranty.
I have no schematic and guessing at present.

Pump not activating for either front or rear wipers.
Wipers work both front and rear.
Appears to all be through same fuse.
Removed wheel right side and inner mud guard to access pump.
Tapped same but nothing.
Unplugged but failed to get a 12v supply at plug even with my son holding the washer switch on.

I would have thought it went basically straight from switch to pump and not through a relay etc.
So if anyone has had this before or has a schematic and can tell me where or what else to check I would be grateful.

I’m just hoping it’s not a wiring loom issue.
Already ordered a new pump thinking that it’s was all it could be but now not sure.

Again if anyone can assist. Thankyou  :phone1:
  • I30 11 Estate(GD) 1.6 CRDI WHITE & same model and year (66)hatchback


Offline A Duke

  • 1st Gear
  • *
    • Posts: 4

    • gb United Kingdom
      Scotland north Lanarkshire
All sorted.
No help needed this time.
New pump fitted and fully operational.
Just need to address the other issue with the glow plugs😬
  • I30 11 Estate(GD) 1.6 CRDI WHITE & same model and year (66)hatchback


Unread Posts

 


SimplePortal 2.3.5 © 2008-2012, SimplePortal