The i30 Owners Club

Parasitic Battery Drain

0 Members and 1 Guest are viewing this topic.

Offline J-Fours

  • 1st Gear
  • *
    • Posts: 1

    • gb United Kingdom
I am having an issue with my 2013 I30 1.4 petrol.

I have had the car about 6months now and it has been very reliable so far but last week it would not start and the battery was dead (9.8v).
I put it down to leaving a light on overnight or something so I jump started it and it ran fine throughout the day. 
Next morning the same thing happened so I charged the battery overnight and it was fine all day but then the next morning the same thing happened so I started looking at parasitic battery drain.
I bought a new 60AH battery in the meantime as the old battery needed replacing anyways. 
The voltage drops around 0.3v overnight and the car is used only every 2 or 3 days for short trips so I realise the battery cant charge on those short distances. I checked last night and it was 12.4v and this morning it was 12.1v.  The car still starts and will charge a little on the short trips but it doesn't keep that charge.
I get a current reading of 0.6A which was with the car locked but I didn't keep the bonnet switch down so it is probably false reading as the car wasn't fully asleep. 
When I pulled the B+3 fuse in the engine bay it dropped to 0.11A.  When pulling the Memory2 fuse in the interior fuse panel it also drops the reading to 0.11A. No other fuses make any change to the current reading.  All interior lights switch off correctly and the car locks with the hazards flashing so I doubt it is a door, boot switch.
I have searched online for days trying to get some information on where else to look.  I read elsewhere that the BCM could be faulty and cause the car not to sleep even though it is locked and the alarm is set.
  • 2013 Hyundai i30


Unread Posts

 


SimplePortal 2.3.5 © 2008-2012, SimplePortal