The i30 Owners Club

i30 cruise control problem

0 Members and 1 Guest are viewing this topic.

Offline 2009i30

  • 1st Gear
  • *
    • Posts: 2

    • ee Estonia
The car is equipped with cruise control. It is connected to the OBD connector. When I connect it, the ESP light comes on. When I disconnect, the ESP light goes out. When I press the ON / OFF button, the green light comes on, but pressing the SET button nothing happens.
If some sensor is out, the ESP light should be on all the time?
2009 i30 1.6 diesel



  • i30


Offline The Gonz

  • Admin
  • *
  • Afghanistan Vet
    • Posts: 16,499

    • au Australia
      Adelaide

  • Callsign GUNZ
It seems that the connections were not made properly. Has it ever worked?
  • Frugal Firty: FDSLXCRDi5spHyperSilverBodyKit+Mods & MrsG'sPDSRPrem


Offline 2009i30

  • 1st Gear
  • *
    • Posts: 2

    • ee Estonia
the car has only been mine for a month. it hasn't worked for me. unfortunately, I cannot ask the previous owner either because he lives in another country. think never it will work once it is installed. I also went to a hyundai dealership and they said they had never seen such a cruise control before.
  • i30


Offline The Gonz

  • Admin
  • *
  • Afghanistan Vet
    • Posts: 16,499

    • au Australia
      Adelaide

  • Callsign GUNZ
In your position, I would hope that the unit is OK and check that all connections have been made according to the instructions: remove it and start again.
  • Frugal Firty: FDSLXCRDi5spHyperSilverBodyKit+Mods & MrsG'sPDSRPrem


Unread Posts

 


SimplePortal 2.3.5 © 2008-2012, SimplePortal