The i30 Owners Club

Rough idle

0 Members and 1 Guest are viewing this topic.

Offline PGN I30

  • 1st Gear
  • *
    • Posts: 5

    • gb United Kingdom
Hi, new member here having recently purchased an i30 diesel 2013.
Not sure if this has happened to anyone else, bought the car and when I got home noticed it would misfire on idle on cold start for about 30 seconds around 600 tp 800 rpm.
After changing the fuel filter and it was no better, started looking at glow plugs, anyway, I removed the glow plug rail with intentions of checking the continuity on the plugs.
I couldn't get a decent reading on any of them so went and ordered some NGK replacements, put everything back together and the next day cold start was good around 1000 rpm dropping as it got warm and very smooth, second day same again so something I've done has miraculously fixed it, may still change the plugs but so far all good, maybe a dodgy connection or glow plug rail connection?
Thanks , already picked up some great advice on this forum before joining.
  • GD diesel estate


Offline PGN I30

  • 1st Gear
  • *
    • Posts: 5

    • gb United Kingdom
Further on from this, after a few days it reverted back to rough idling again, changed the plugs yesterday, it had the original hyundai plugs with 86k on the clock, first cold start today seems good so hopefully that's it.
  • GD diesel estate


Offline Lorian

  • V.I.P
  • *
    • Posts: 3,434

    • gb United Kingdom
      Midlands

  • Midlands, UK N-Line T-GDi
Make sure the heatshield is not arcing/shorting to the rail (common)


Offline mrexcitement

  • 2nd Gear
  • *
    • Posts: 71

    • au Australia
      Melbourne
Also make sure the metal power rail to the glow plugs is not bent and shorting on the engine , this was the case on my I30 diesel , also check the glow plug fuse (it can be checked by visually looking at it from the top) as it was blown on mine because of the power rail shorting.

The glow plug fuse is bolted in place so you need to get underneath the fuse box and undo the bolts to remove it.

I think the fuse was blown for a little while on mine , I never thought of checking it initially as the car was still starting ok with the blown fuse.
  • 2010 FD WAGON ,DIESEL 1.6, AUTO, SKY BLUE


Unread Posts

 


SimplePortal 2.3.5 © 2008-2012, SimplePortal