The i30 Owners Club

2009 I30 CRDI SX 1.6 Turning over, but not starting (Intermittend)

auke · 5 · 2003

0 Members and 1 Guest are viewing this topic.

Offline auke

  • 1st Gear
  • *
    • Posts: 6

    • au Australia
      Brisbane
2009 I30 CRDI SX 1.6 Turning over, but not starting (Intermittend)

Normally the I30  immobiliser light turns off when you turn to start cranking and the car will fire up. If your imobiliser does not recognise your key the imobiliser light will be flashing during starting/cranking and will not fire up. (Expirienced this in the past, when I got a new key cover and the key clip had not been transfered into the new key cover)

My issue today is that sometimes during cranking the engine does not fire up and the immobiliser light stays on solid during cranking.

After an hour or so when I turned the key, everything is back to normal car running and no issues for another week.
Today while the car was idleling the engine suddenly shut off with the immobiliser light on solid and would not fire up again. After about an hour waiting, for roadside assistence, I turned the key and the engine fired up again and I drove home with no issues. Car running perfectly fine again.

It has happend now twice in the last week, both times the car had innitially started up fine, driven for 10 minutes, so the engine was at normal running temperature when it occurred

Note: New battery, diesel filter done 5000km ago, glow plugs replaced 3 years ago.

Anyone had any simular issues??????????????
Can anyone help me????
« Last Edit: October 04, 2022, 06:15:56 by auke »
  • I30 CRDI SX


Offline Piejar

  • 1st Gear
  • *
    • Posts: 7

    • pl Poland
Had this issue for some years. This is rather antenna issue - mine was ok, it had ohms during measurement. Only thing I did, I cleaned contacts and bent them a little to make connector a bit tighter.
I did that some 2 years ago and issue is gone.
To access antenna connector remove lower part of steering column cover. It's not necessary to unmount immo coil, just measure it and if it's ok focus on connectors.
  • 2009 FD 5 Door CW, Diesel 1.6lt, Manual, Silver


Offline auke

  • 1st Gear
  • *
    • Posts: 6

    • au Australia
      Brisbane
I think I found the issue.
The last time it happened suddenly the Fault Code P0335 came up: The Crank Position Sensor.
Disconnnected it and I could replicate the immobiliser light coming on again.

Measuring between Pin 2 and 3 should normally read around 850 Ohm.
When I put the heatgun on, it went up past 2KOhm and then into overload.

I'll post again when I have replaced the sensor and have eliminated the problem.
  • I30 CRDI SX


Offline auke

  • 1st Gear
  • *
    • Posts: 6

    • au Australia
      Brisbane
Ploblem has not been solved, after 30 min of driving the engine shut off again without warning in the middel of traffic.
First attemp to start the immobiliser light stayed on and engine did not start.
But it started again on second attempt and immobiliser light turned off. Drove home agin without any issues.

Checking the fault codes  after incident:
P1186 Manufacturer Defined

Checked the codes again a bit later and it was replaced with:
P2112 Throttle Acuator System - Stuck Closed.

Any help ??




« Last Edit: October 23, 2022, 16:01:14 by auke »
  • I30 CRDI SX


Offline Piejar

  • 1st Gear
  • *
    • Posts: 7

    • pl Poland
Try to check contacts on immo antenna - I wrote about. It s strange that engine has stopped - it never happened to me, but immo lamp issue is exactly the same like mine.
Your unsolved error: (Google translator :-))
:link: P1186 - Hyundai, Kod błędu OBD 2

Connected with dual pressure. But throttle stucked closed - also interesting
  • 2009 FD 5 Door CW, Diesel 1.6lt, Manual, Silver


Unread Posts

 


SimplePortal 2.3.5 © 2008-2012, SimplePortal