Author Topic: HOW TO: UPGRADE YOUR GD-01/GD-02 TO A GD-03 HEAD UNIT STEP-BY-STEP GUIDE  (Read 14514 times)

0 Members and 3 Guests are viewing this topic.

  • *
  • Posts: 150
  • cy Cyprus
At the end of the day I am stuck with no aux music neither bluetooth for making calls....

One way of fixing that clicking noise...  :snigger:

All you can do is keep working through the steps as explained by Craig.  :undecided:
I already tried 4 times with no luck I think the only way is to get a new unit if I donít sort this out. By the way which clicking noise are you talking about?

Wasn't it you that was having the Apple music clicking noise? :undecided:
No! I updated the unit to the latest software and now I have no sound when I plug any usb or bluetooth device. The u it displays song name and everything but no sound.


  • Hyundai i30 2012

  • *
  • Posts: 8,838
  • au Australia
    Perth
One last thought...try downloading another copy of the file and start fresh.

If update is done correctly the phone and everything else should be wiped from the stereo requiring you to re-sync phone and retune radio stations.


  • *
  • Laughter is the best medicine. .
  • Posts: 61,562
  • au Australia
    Devonport Tasmania
  • Best Car Forum on the Net
At the end of the day I am stuck with no aux music neither bluetooth for making calls....

One way of fixing that clicking noise...  :snigger:

All you can do is keep working through the steps as explained by Craig.  :undecided:
I already tried 4 times with no luck I think the only way is to get a new unit if I donít sort this out. By the way which clicking noise are you talking about?

Wasn't it you that was having the Apple music clicking noise? :undecided:
No! I updated the unit to the latest software and now I have no sound when I plug any usb or bluetooth device. The u it displays song name and everything but no sound.

Yes it was..

:link: Cartronics TL-01, DM-01, AD-01, FS-02 & GD-03 v2.05.05 Firmware (Aug 28, 2018)
  • MY18 PD SR & 2014 1.6 GDi Tourer (Prev had 2008  i30 CRDi & MY11 Petrol CW)

  • *
  • Posts: 150
  • cy Cyprus
HOW TO: UPGRADE YOUR GD-01/GD-02 TO A GD-03 HEAD UNIT STEP-BY-STEP GUIDE
« Reply #183 : October 08, 2018, 03:27:23 »
At the end of the day I am stuck with no aux music neither bluetooth for making calls....

One way of fixing that clicking noise...  :snigger:

All you can do is keep working through the steps as explained by Craig.  :undecided:
I already tried 4 times with no luck I think the only way is to get a new unit if I donít sort this out. By the way which clicking noise are you talking about?

Wasn't it you that was having the Apple music clicking noise? :undecided:
No! I updated the unit to the latest software and now I have no sound when I plug any usb or bluetooth device. The u it displays song name and everything but no sound.

Yes it was..

:link: Cartronics TL-01, DM-01, AD-01, FS-02 & GD-03 v2.05.05 Firmware (Aug 28, 2018)
Yes, I had and I already have that problem along with the rest of iOS 12 users hahahah! But I donít use the carplay any more because of that!
« Last Edit: October 08, 2018, 03:38:04 by aanastasiou4 » »
  • Hyundai i30 2012

  • *
  • Posts: 150
  • cy Cyprus
One last thought...try downloading another copy of the file and start fresh.

If update is done correctly the phone and everything else should be wiped from the stereo requiring you to re-sync phone and retune radio stations.
This is what my radio was like after finishing the update! No radio stations. or any bluetooth devices were stored. Okay, I will try again!


  • Hyundai i30 2012

  • *
  • Posts: 8,838
  • au Australia
    Perth
One last thought...try downloading another copy of the file and start fresh.

If update is done correctly the phone and everything else should be wiped from the stereo requiring you to re-sync phone and retune radio stations.
This is what my radio was like after finishing the update! No radio stations. or any bluetooth devices were stored. Okay, I will try again!
I can only assume something has gone wrong in the update process, there are reports on the web and here of some having clock reset issues though I've not read any reports of the no sound issue you described, just seems strange how I have the same upgraded GD-03 unit and don't see any of the issues others are reporting :confused: though I dd cut the reverse wire and haven't connected the AUX port, only the USB port is connected for myself.

  • *
  • Posts: 150
  • cy Cyprus
One last thought...try downloading another copy of the file and start fresh.

If update is done correctly the phone and everything else should be wiped from the stereo requiring you to re-sync phone and retune radio stations.
This is what my radio was like after finishing the update! No radio stations. or any bluetooth devices were stored. Okay, I will try again!
I can only assume something has gone wrong in the update process, there are reports on the web and here of some having clock reset issues though I've not read any reports of the no sound issue you described, just seems strange how I have the same upgraded GD-03 unit and don't see any of the issues others are reporting :confused: though I dd cut the reverse wire and haven't connected the AUX port, only the USB port is connected for myself.
I guess I have to live with it until a new update comes out... I donít have the clock reset issue though!


  • Hyundai i30 2012

  • *
  • Posts: 8,838
  • au Australia
    Perth
I wonder if you could try contacting Cartronics and describe your problem with the new update file and ask if they would be kind enough to send the previous file to you  :Good_luck: support@cartronics.net.au

  • *
  • Posts: 150
  • cy Cyprus
I wonder if you could try contacting Cartronics and describe your problem with the new update file and ask if they would be kind enough to send the previous file to you  :Good_luck: support@cartronics.net.au
I will do that thanks! I just noticed that my clock resets back to 12:00 am too!


  • Hyundai i30 2012

  • *
  • Posts: 31
  • gb United Kingdom
    Stoke on Trent United kingdom
Hello, another quick update.
USB module is all hooked up now and it is working fine. I even tried a USB hub to connect my phone and a USB stick at the same time and it does work, which is fantastic as I can still play the music stored on the USB stick whilst using android auto  :goodjob2:
Also my unit is on 2.04.07 firmware, is it wise to keep it as it is?  And wait until a new update will be released
  • I30 2013 GD 5 Door Hatchback Petrol 1.4 Manual Active

  • *
  • Posts: 8,838
  • au Australia
    Perth
Also my unit is on 2.04.07 firmware, is it wise to keep it as it is?  And wait until a new update will be released
Might as well leave it as is, even though I have no issues with the update on mine there wasn't any noticeable improvements on any other features I can tell.

  • *
  • Posts: 5
  • au Australia
    Australia
Hello All

Some further updates having had the upgrade in for 2 weeks with the latest firmware.

1) The firmware is not causing me issues but I also have a cut reverse cable so the unit will not pick up reverse

2) Gosh the whole combo  is buggy ( iPhone 7 or 6s, cable, ioS12/.01 and GD-03 Head and whatever car play app you run ).

EG

        a) Waze talks and AM band audio is turned down automatically, on waze being done, AM audio is like you are 100KM form the transmitter - full of static. You need to power off the radio and all fine then. FM doesn't seem to have the issue.
        b) Random disconnects - seems helped greatly if you shut down ( swipe away ) all the other background apps that may be running on the iPhone. Various cables make no change
        c) Once ( in only two weeks ) after about 30 seconds of starting and maps talking fine the audio became a loud screech on any input, like audio feedback - USB, Bluetooth etc and thence to silence. Disconnecting phone and power cycling radio no change. After the car was turned off though it went back to normal

        d) Siri works about 50% better understanding what you said if the iPhone is on speaker phone rather than via the voice button on the unit


I would have been happy to say cartronics is crap at software but a friend with a VW Polo has constant issues too ( not sure of manufacturer of head unit ) and as above, there are so many places for bugs from phone to car. I would be curious what everyone else finds, especially those with an original factory fit.

I still enjoyed the fun of having done the job but some of the gloss is gone. If I had paid more than $200 from a wrecker I wouldn't be amused. Maybe I understand why the likes of Toyota and Mazda have been slow to release apple car play. In OZ law you need to get what you paid for and if the bloody thing crashes every second trip it would be a grey area if carplay meets that test. Does capplay do what you paid for in the advertisements?

Hopefully over the next year of so the bugs get ironed out but carplay isn't exactly new!
« Last Edit: October 16, 2018, 20:15:20 by RedCari30 » »
  • 2013 GD 5 Door Hatch, Petrol 1.8lt, Auto, Red

  • *
  • Laughter is the best medicine. .
  • Posts: 61,562
  • au Australia
    Devonport Tasmania
  • Best Car Forum on the Net
Interestingly, I am having mixed experiences with Android Auto in my PD. At one stage it was working seamlessly,  but now rather than press the voice command on the wheel I'm getting better results just saying ok google.  :crazy1:

Still been a bit buggy lately even using that option.  :Pout:
  • MY18 PD SR & 2014 1.6 GDi Tourer (Prev had 2008  i30 CRDi & MY11 Petrol CW)

  • *
  • Posts: 8,838
  • au Australia
    Perth
Hello All

Some further updates having had the upgrade in for 2 weeks with the latest firmware.

1) The firmware is not causing me issues but I also have a cut reverse cable so the unit will not pick up reverse

2) Gosh the whole combo  is buggy ( iPhone 7 or 6s, cable, ioS12/.01 and GD-03 Head and whatever car play app you run ).

EG

        a) Waze talks and AM band audio is turned down automatically, on waze being done, AM audio is like you are 100KM form the transmitter - full of static. You need to power off the radio and all fine then. FM doesn't seem to have the issue.
        b) Random disconnects - seems helped greatly if you shut down ( swipe away ) all the other background apps that may be running on the iPhone. Various cables make no change
        c) Once ( in only two weeks ) after about 30 seconds of starting and maps talking fine the audio became a loud screech on any input, like audio feedback - USB, Bluetooth etc and thence to silence. Disconnecting phone and power cycling radio no change. After the car was turned off though it went back to normal

        d) Siri works about 50% better understanding what you said if the iPhone is on speaker phone rather than via the voice button on the unit


I would have been happy to say cartronics is crap at software but a friend with a VW Polo has constant issues too ( not sure of manufacturer of head unit ) and as above, there are so many places for bugs from phone to car. I would be curious what everyone else finds, especially those with an original factory fit.

I still enjoyed the fun of having done the job but some of the gloss is gone. If I had paid more than $200 from a wrecker I wouldn't be amused. Maybe I understand why the likes of Toyota and Mazda have been slow to release apple car play. In OZ law you need to get what you paid for and if the bloody thing crashes every second trip it would be a grey area if carplay meets that test. Does capplay do what you paid for in the advertisements?

Hopefully over the next year of so the bugs get ironed out but carplay isn't exactly new!
I had the occasional disconnect of the phone from head unit if the phone was laying down somewhere (fixed buy pulling USB for 10 seconds and replacing) though when upright on its mount it's fine, my voice on the unit works well.

Never used AM so I cant comment on that, though I believe most AM stations are also available on FM now days :undecided:

Only real issue I get is the Car Play clicking noise when listening to music but that's an Apple issue we're all waiting for them to rectify.

  • *
  • Posts: 31
  • england England
    Basingstoke, Hampshire
Thanks so much for all the helpful information here.

I was having some issues with my third party Android head unit so thought I would give the GD-03 a go.

Managed to get one to the UK from Australia and fitted it this morning before work. I got the new HU, Aux unit, and USB cable all fitted with a snipped and taped A9 cable, firmware updated from 2.0 to 2.05.05 (I couldn't find the 2.04.x firmware anywhere) all in just over an hour and everything seems to be working well :D

Thanks again,

LP
  • 2015 GD 5 Door Hatch, Petrol 1.4lt, Manual, Black

  • *
  • Laughter is the best medicine. .
  • Posts: 61,562
  • au Australia
    Devonport Tasmania
  • Best Car Forum on the Net
That's great to hear LP. Well done.  :goodjob2: :goodjob:
  • MY18 PD SR & 2014 1.6 GDi Tourer (Prev had 2008  i30 CRDi & MY11 Petrol CW)

  • *
  • Posts: 31
  • gb United Kingdom
    Stoke on Trent United kingdom
Thanks so much for all the helpful information here.

I was having some issues with my third party Android head unit so thought I would give the GD-03 a go.

Managed to get one to the UK from Australia and fitted it this morning before work. I got the new HU, Aux unit, and USB cable all fitted with a snipped and taped A9 cable, firmware updated from 2.0 to 2.05.05 (I couldn't find the 2.04.x firmware anywhere) all in just over an hour and everything seems to be working well :D

Thanks again,

LP

Great stuff!
It is buggy at times, where as it won't change audio volume at time's unless the voice command is pressed then cancelled. Also the skip song button sometimes stops working on the steering wheel. 
Other than that great. 
I do also have a usb hub so I have my usb stick and phone plugged in at the same time
  • I30 2013 GD 5 Door Hatchback Petrol 1.4 Manual Active

  • *
  • Posts: 8,838
  • au Australia
    Perth
It is buggy at times, where as it won't change audio volume at time's unless the voice command is pressed then cancelled. Also the skip song button sometimes stops working on the steering wheel. 
Other than that great. 
I do also have a usb hub so I have my usb stick and phone plugged in at the same time
I wonder if those issues are related to a problem in your steering wheel controls being worn :undecided: I see none of those problems here.

  • *
  • Posts: 31
  • gb United Kingdom
    Stoke on Trent United kingdom
It is buggy at times, where as it won't change audio volume at time's unless the voice command is pressed then cancelled. Also the skip song button sometimes stops working on the steering wheel. 
Other than that great. 
I do also have a usb hub so I have my usb stick and phone plugged in at the same time
I wonder if those issues are related to a problem in your steering wheel controls being worn :undecided: I see none of those problems here.

On the drive home from work I have noticed that these issues only occur when I try to change the volume, but instead of it changing the audio volume it will change guidance volume. Once I press the voice command button then again to cancel it the controls return to normal and work fine. Something is happening to make the guidance volume change instead of the audio, not sure what or how this happens but it is random.
It seems to me that the unit thinks that it is either listening/waiting for a voice command or something to do with the maps. I am going to look through my android auto settings and Google assistant to see if there's anything I can change.
  • I30 2013 GD 5 Door Hatchback Petrol 1.4 Manual Active

  • *
  • Posts: 8,838
  • au Australia
    Perth
Guidance volume should only change while directions are being spoken, once speech has stopped then audio (music) volume should be available again, that's how it works on mine.

  • *
  • Use it or lose it!
  • Posts: 14,360
  • au Australia
    Adelaide
  • Callsign GUNZ
    • Professional Biography
Based on what you just said, Craig, perhaps the background volume the unit is getting is so high that it's heard as speech. :Dunno:
  • Frugal Firty: FDSLXCRDi5spHyperSilverBodyKit+Mods & MrsG's PDSRPremAuto

  • *
  • Posts: 8,838
  • au Australia
    Perth
Based on what you just said, Craig, perhaps the background volume the unit is getting is so high that it's heard as speech. :Dunno:
Not sure, my phone volume is set to max for music and 60% for ringer and calls, the head unit defaults to 8 for guidance every time the vehicle is started which I'll turn up as needed via steering wheel controls while guidance is being spoken, in-between directions (guidance waiting)  I can adjust music/radio volume which defaults to 12 at startup that I've pre-set in the head-unit settings.

  • *
  • Posts: 31
  • england England
    Basingstoke, Hampshire
I had this on my first drive this morning.

As it happens Waze was on "No sound mode", when I enabled sound the volume control worked correctly: Adjusting Guidance volume when Waze was speaking, and Media when Waze wasn't.

Untested theory: Volume adjusts Guidance when Waze *would* be speaking, even if set to "No sound"....

The main issue I am having seems to be specific to Spotify. Sometimes Spotify is playing but there's no sound. All other apps are fine. I think this is due to Spotify having support for remote control of devices on the same account and getting its knickers in a twist...
  • 2015 GD 5 Door Hatch, Petrol 1.4lt, Manual, Black

  • *
  • Posts: 31
  • england England
    Basingstoke, Hampshire
I know it's not the point of the GD-03, but my word the radio functionality is the most basic I've seen in forever. Doesn't even read the RDS info like channel names.
  • 2015 GD 5 Door Hatch, Petrol 1.4lt, Manual, Black

  • *
  • Posts: 8,838
  • au Australia
    Perth
I know it's not the point of the GD-03, but my word the radio functionality is the most basic I've seen in forever. Doesn't even read the RDS info like channel names.
I thought channel names were only read out with DAB units :undecided: I think DAB functionality is in the latest 2018 i30 units though even if I had it I would never see it as I always have Apple Car Play connected and running.

You can always upgrade to an aftermarket system if you want :)

  • *
  • Posts: 31
  • england England
    Basingstoke, Hampshire
Nah, RDS has been about since the late 90s, every car stereo I have ever had has shown channel names, until this one.

I'm coming to GD-03 from an Android aftermarket head unit. It was great but with annoying bugs.

I will almost always be using Android Auto so it's not a problem, just weird.
« Last Edit: October 21, 2018, 08:16:14 by LargePig » »
  • 2015 GD 5 Door Hatch, Petrol 1.4lt, Manual, Black

  • *
  • Posts: 31
  • england England
    Basingstoke, Hampshire
Weird, on reading it looks like RDS features didn't take off much in Australia.

Things like automatic frequency switching, traffic announcements, channel names, all useful!

It was even on the Bobby basic radio that my i30 came with.
  • 2015 GD 5 Door Hatch, Petrol 1.4lt, Manual, Black

  • *
  • Posts: 8,838
  • au Australia
    Perth
Weird, on reading it looks like RDS features didn't take off much in Australia.

Things like automatic frequency switching, traffic announcements, channel names, all useful!

It was even on the Bobby basic radio that my i30 came with.
Yeah not a big thing here that I know of though some cars may have it :undecided: mostly AM/FM with CD which the latter is being phased out now that Apple and Android are the in thing, all radios are gradually moving to DAB.

I've got DAB on the house stereo and it's better sound and signal than FM :)

  • *
  • Posts: 2,286
  • au Australia
    Tura Beach ( Deep Deep South Coast) NSW
Weird, on reading it looks like RDS features didn't take off much in Australia.

Things like automatic frequency switching, traffic announcements, channel names, all useful!

It was even on the Bobby basic radio that my i30 came with.

We're ymp immp imbl simple flok down 'ere.  :lol:
  • 09/16 GD4 SII Active X 5dr 1.8 6sp A. 02/18 DM5 Santa Fe H/lander 2.2 6sp white

  • *
  • Posts: 1
  • VIC
CONFIRMED. I GOT AUX TO WORK, at least in the american elantra gt - non sat/nav. This should theoretically work for the i30 as well.

I acquired the extension cable from a santa fe to the usb dock, that I assume runs to a lower point on the console. Part #961202W500. Removing the female end connector I was able to connect the cable and its 8 wires to the needed connections with the existing 16pin connector via t-tap connectors, and connected the male end to the 96120A5100 usb aux connection. :link: Amazon.com: Ginsco 120 Pcs/60 Pairs Quick Splice Wire Terminals T-Tap Self-stripping with Nylon Fully Insulated Male Quick Disconnects Kit: Home Improvement. This allows me to remove the HD-03 in the event that I want to add back the stock radio and without directly cutting the 16pin harness.

Just matched up the connections from the new to the old. It only works if you have the USB, as it provides power for the aux connection.













Hey - thanks for your guide. I've had a hard time matching up the wires based off the two images you send of the pin-outs. What do you do with AUX Video, Illumination, and AUX Video Ground?

Annotated your picture of the GD-03 end. If you could remember what the matching was that would be seriously helpful! thanks.



  • i30 2015 1.6L Diesel